Chevy Corvette Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter · #1 ·
:burnout: i don't think it is a problem BUT last night I was sitting in my vette and it was ideling and the temp went up over about 20 min got close to 250 then fans came on and went to about 230 anything I can do to have the fan come on sooner? I don't like the high numbers. It did not over heat.:SMILEY:
 

·
Registered
Joined
·
836 Posts
Yep U can Put Reostats in the line & Get Them to Kick in Whenever U Want.... I Run 2 of them For Both Fans . & Have them Kick in at Different Temps !! Advance sells them For about 20.00 ea.
:burnout:
 

·
Registered
Joined
·
5,563 Posts
or get a real radiator , any other "fix" is just a band-aid
the stock ones are too friggin small
 

·
Registered
Joined
·
5,563 Posts
I put a Alum Radiator in my 88 & Still Had Problems . So I Put The Reostats in & that Cured it ! :thumbsup3:
what type ?
2 row ?
3 row ?
Brand ?
 

·
Registered
Joined
·
5,563 Posts
3 took it down to 220 on a hot day & I Paid Too Much For it !!!
something is wrong
sounds like the wrong type of core
a good one will cost between 600-700 bucks
the $200 generic ones just don't get it done unless you run pure methanol
 

·
Registered
Joined
·
2,849 Posts
the temp went up over about 20 min got close to 250 then fans came on
It did not overheat
How do you know your temp gauge is reading accurate?
Have you confirmed the gauge reading by other means?

anything I can do to have the fan come on sooner?
:SMILEY:
If you told us what year you are talking about it would be a big help.
Lottsa differences in fan control over 12 years of C4's
 

·
Registered
Joined
·
148 Posts
Discussion Starter · #10 · (Edited)
looks like it's running warm

I HAVE A 96 LT4 . No I did not confirm temp any other way just gauge. but it smells hot you know the smell of hot water it never went up like this ,think I will goto auto zone ot Advanced auto and get the reostats car sat all winter maybe just stickey kep you posted. first cruise coming up Sunday baby is ready:thumbsup3: lostvette what temps they set at ??
 

·
Registered
Joined
·
2,849 Posts
I did not confirm temp any other way just gauge.
The analog gauge or the digital gauge?
The analog gauge is "indicative" only ;well know to be inaccurate at the top of it's travel
The digital temp gauge is the only one that will give true coolant temp; does it display same temp as the analog gauge?

In any case even if the temps you are seeing were right, it is not overly hot based on stock setting were the fan is set to run at 228F
The GM manual says to turn the engine off and let it cool down if it gets to 260F ( actual )
 

·
Registered
Joined
·
5,563 Posts

·
Registered
Joined
·
5,563 Posts
That makes no sense then.....
is your air dam on ?
is the condenser clogged ?
there is no way you should have any need to fiddle with the fans with a DeWitts
 

·
Registered
Joined
·
148 Posts
Discussion Starter · #15 ·
water temp looks high

:SMILEY:Guys I drained the radiator,tank, and expantion tank . Put in 1 1/2 gallons of Dex cool took it for a ride and temp stayed a t 185. Maybe the mix I had was old???? Any way it seems to be allrieght no . I let it idle about 15 min still never went up Case closed.:seeya:
 
1 - 15 of 15 Posts
Top