Chevy Corvette Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
My '76 Vette has a lot of issue's but the one that was really bothering me was no turnsignal's. There is a rats nest of hilljacked wiring under the dash from someone before trying to wire god knows what. I was afraid to remove this stuff as I didn't know what they had tied into what. Today I finally sovled the mystery of the blinkers. The fuse (second from top on right side '76's) in the fusebox that controls them was not making good contact.:thumbsup3: Something simple that gave me weeks of fits.
Now I've removed about 30 ft. of idiot wiring that has nothing to do with the car operating. It's all traced back to a jacked up stereo thats outta here! :479:
 

·
Registered
Joined
·
584 Posts
My '76 Vette has a lot of issue's but the one that was really bothering me was no turnsignal's. There is a rats nest of hilljacked wiring under the dash from someone before trying to wire god knows what. I was afraid to remove this stuff as I didn't know what they had tied into what. Today I finally sovled the mystery of the blinkers. The fuse (second from top on right side '76's) in the fusebox that controls them was not making good contact.:thumbsup3: Something simple that gave me weeks of fits.
Now I've removed about 30 ft. of idiot wiring that has nothing to do with the car operating. It's all traced back to a jacked up stereo thats outta here! :479:
:thumbsup3:
:2ni19wj:
 

·
Super Moderator
Joined
·
5,976 Posts
My '76 Vette has a lot of issue's but the one that was really bothering me was no turnsignal's. There is a rats nest of hilljacked wiring under the dash from someone before trying to wire god knows what. I was afraid to remove this stuff as I didn't know what they had tied into what. Today I finally sovled the mystery of the blinkers. The fuse (second from top on right side '76's) in the fusebox that controls them was not making good contact.:thumbsup3: Something simple that gave me weeks of fits.
Now I've removed about 30 ft. of idiot wiring that has nothing to do with the car operating. It's all traced back to a jacked up stereo thats outta here! :479:
Had the same thing when I bought my '75. Aftermarket stereo with amp and speakers and a huge pile of wires. Yanked it all out and sold on Craigslist in under an hour.
 
1 - 3 of 3 Posts
Top