Chevy Corvette Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
98 vert 90k running fine until yesterday. Turning ignition key got some indication of car firing then nothing. Nothing in DIC to show codes. Check engine light lit dimly. After several attempts to start the starting motor would not activate.
Left it alone overnight. Today attempted to start. Turning ignition on got "Corvette" only as the start up message not the whole startup message then DIC went blank. Check engine light on, This time strong cranking for about 12 seconds but did not seem to fire at all like it did yesterday. Again unable to access any codes on the DIC readout.
Could be electrical, could be no fuel. The check engine light says the car knows something is wrong.
Any ideas on what is going on or how to diagnose and fix this problem?
bighank is offline
Reply With Quote
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
Battery is only 3 months old but new does not mean good. Charged battery for over 24 hours with car electrical system disconnected. Reconnected terminals on battery. Voltage is about 12.5 with ignition turned off. Got partial DIC message "Corvette" then blank. Tried to read codes using Options and Fuel 4 times but nothing shows up. Tried to start car and got absolutely NOTHING. Connected jumper cables to another vehicle with engine running. Voltage read at Corvette battery with digital voltmeter now about 14.4 volts. Put key in ignition and turned it on but didn't turn to start. Got LOW VOLTAGE and REDUCED ENGINE POWER on DIC. Turned key to start and car cranked very fast but no start. Cranked for about 15 seconds and still no start. Tried this 2 more times. Now DIC says LOW VOLTAGE and 6.0 V battery. After several cranking attempts voltage dropped down to 5.6 V.
Either no spark or no fuel. Gas tank is full. Still cannot access normal functions from DIC and cannot access stored codes using OPTIONS and FUEL buttons.
What next? Bad ground? Computer malfunction? CHECK ENGINE LIGHT is on.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
Used an OBD code reader and got code P1518 - Power Control Module to throttle actuator control module serial data circuit code.
Using google found that this may be a bad connection in the wires going from these 2 modules or maybe a bad ground rather than the modules being defective.

Where are these modules?
Where are the serial data circuit wires and connectors?
What is the usual cause of this condition?

Car cranks very well but will not start.
bighank is offline
 
1 - 6 of 6 Posts
Top