Chevy Corvette Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I had my c 69 vet restored and finished in Sept 2010. Drove it about 100 miles since. Driving it yesterday and heard what sounded to be a hole in the muffler and sputtering. Drove another 5 moles to get closer to home at 20 mph. Drove ok but then started making more noise. Stopped and turned off everything. Checked the oil and bone dry!!! Put oil in it and sounded ok but still heard a pop. Had the engine rebuilt last year. Sounds like I screwed up as I assumed that the restorers would have put new oil in the thing. I feel so stupid. How do I know if damage was done? No oil was leaked so I didn't think that the oil was so low. Car starts and once warm makes no noise, but the occasional pop. Under air cleaner on motor appears to be a brown mark on orange paint. Got to be a bad.
 

·
Registered
Joined
·
5,563 Posts
nothing good happens when a motor is run without oil
personally , I'd pull it out and look at the internals
 

·
Registered
Joined
·
9,695 Posts
I had my c 69 vet restored and finished in Sept 2010. Drove it about 100 miles since. Driving it yesterday and heard what sounded to be a hole in the muffler and sputtering. Drove another 5 moles to get closer to home at 20 mph. Drove ok but then started making more noise. Stopped and turned off everything. Checked the oil and bone dry!!! Put oil in it and sounded ok but still heard a pop. Had the engine rebuilt last year. Sounds like I screwed up as I assumed that the restorers would have put new oil in the thing. I feel so stupid. How do I know if damage was done? No oil was leaked so I didn't think that the oil was so low. Car starts and once warm makes no noise, but the occasional pop. Under air cleaner on motor appears to be a brown mark on orange paint. Got to be a bad.
As a professional mechanic for 45 years I check my oil level about once a week and before making any trip of 100 miles or more. When you say it didn't have any oil in it did you happen to drain it and measure how much it still had? Or did you just dump oil in it? If there wasn't any main/rod bearing damage it should have good oil pressure.
 

·
Premium Member
Joined
·
9,048 Posts
how much oil did you need to add? is the motor knocking now? How much oil pressure do you have hot ? is the popping coming from carb or exhaust? any smoke?
 

·
Registered
Joined
·
22 Posts
No oil at all or low on oil?? I would think if you had no oil it would have seized up. Pull the valve covers off. If you broke a rocker or a push rod you'll get a popping through the carb. if the valve isn't opening. I've seen that happen a lot. Good luck!
 
1 - 6 of 6 Posts
Top