Chevy Corvette Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
669 Posts
Discussion Starter #1
Sometimes after the car is up to operatring temps and shut the motor off then restart it latter the motor still at operating temp it will rev to 3500 to 4500 RPM's then go down to 1000 RPM after a couple seconds WHY.



I dont have any vacume leaks the base Idle is set at 450 RPM's the Normal timiming set a 6 advance.



Most of the time in gear the Idle is at 650 to 700 RPM In gear it's a uto trans.



The motor not stock it a mild build it has a chip for the mods.



I dont remember the motor doing this before the rebuild from stock motor.



It will also surge when slowing down moving foward to a idle 650/700 Rpm's to 1000 Rpm's I think it's the TQ convertor the place that rebuild the trans screwed it up I still working getting anouther trans.
 

·
Registered
Joined
·
669 Posts
Discussion Starter #3
The IAV is New
 

·
Registered
Joined
·
669 Posts
Discussion Starter #4
Adjusted the TPS to .539 Volts it was at .55

Put the old Spare MAF back on It runs great now.
 

·
Registered
Joined
·
669 Posts
Discussion Starter #6
Thanks I think I gotten 98% of the know engine problems fixed now It been a learning curve for me this Vett.

Next is the weak link getting the Trans right I still dealing with the POS the trans shop built me.

I be working some OT to get a New Trans.

Oh ya also a new set of Comp Cam Steel Roller Rocker arms and a custom Tune I getting there.
 

·
Registered
Joined
·
9,695 Posts
Thanks I think I gotten 98% of the know engine problems fixed now It been a learning curve for me this Vett.

Next is the weak link getting the Trans right I still dealing with the POS the trans shop built me.

I be working some OT to get a New Trans.

Oh ya also a new set of Comp Cam Steel Roller Rocker arms and a custom Tune I getting there.

So what is your transmission doing that is abnormal? I have rebuilt about a dozen of them so I know a lot about them. You might just have a miss-adjusted TV cable.
 

·
Registered
Joined
·
669 Posts
Discussion Starter #8
So what is your transmission doing that is abnormal? I have rebuilt about a dozen of them so I know a lot about them. You might just have a miss-adjusted TV cable.
It shifts soft and it has a transgo shift kit in it.

Shifting between gears when you have you foot to the floor it will Flair it shiftse at 4500 Ish then spin up to 6000 and slid into the next gear I normaly by this time pull my foot off the gas.

I learned how to drive it when it get to the shifting point back out of the gas untill the shifting done or it will Flair up.

I am for now trying get it to last until I save enough money to buy anouther trans.

Ansd I will not bring it back to the trans shop that did the work never again it was there the first time for 2 weeks the sencond time it was there a full month and screwed the car up I going though the BBB and the Bar now trying to get my money back.
 

·
Registered
Joined
·
9,695 Posts
It shifts soft and it has a transgo shift kit in it.

Shifting between gears when you have you foot to the floor it will Flair it shiftse at 4500 Ish then spin up to 6000 and slid into the next gear I normaly by this time pull my foot off the gas.

I learned how to drive it when it get to the shifting point back out of the gas untill the shifting done or it will Flair up.

I am for now trying get it to last until I save enough money to buy anouther trans.

Ansd I will not bring it back to the trans shop that did the work never again it was there the first time for 2 weeks the sencond time it was there a full month and screwed the car up I going though the BBB and the Bar now trying to get my money back.

For starters adjust your TV cable so it's JUST tight (not real tight) at wide open throttle. If it shifts too hard for your liking back off the cable about 1/32" at a time until it shifts smoothly. You say it will "flair up"? Are you saying your engine will suddenly accelerate when your engine gets into it's torque band? If so it sounds like your engine's torque is exceeding the clutch's holding capacity and the clutches (or band) are slipping. As a slipping clutch pack or band will burn up very quickly DO NOT allow it to slip. Try adjusting your TV cable first and let me know how it turns out. I'd like to know what your oil looks like. You can suck it out of the dip stick tube with a cheap readily available suction gun and a length of clear plastic tubing fastened to the gun. If the oil is no longer a bright red and it stinks it has been grossly overheated and very likely you have clutch pack/band damage.
 

·
Registered
Joined
·
9,695 Posts
Marv02, if your transmission is shot bring it up to my place and we'll overhaul it together. I'll show you how unbelievably easy it is. I live about 30 miles due east of Fresno so I'm well within driving distance from your house. You can do the wrench turning as I tell you what to do. And bring your torque converter so we can put a 1/8" NPT drain plug in it. I just got done doing a TH700R4 swap into my 454" powered 1971 and I built it to handle 600ft/lbs of torque.
 
1 - 10 of 10 Posts
Top