Chevy Corvette Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I recently bought my first Corvette. Got the car for $500 put in a new battery And after having sat exposed to the elements gor over ten years it started right up. I drove it for about a month and on my way home from work about three weeks ago it died. I still had power but it Would not start back up and so I had to tow it home. I had a friend come over to help me look at it we turned it over only to hear what I had thought was a bad water pump but it turned out to be a bad smog pump so I Put everything back together and since then the car cranks but will not run. If I hit it with starting fluid It will run until it burns up that fuel then dies. Noticed that I’m not getting the two second fuel pump turn on when I first turn the key. If I jump the ALDL With a hot wire the pump will turn on and give 40psi @ the fuel rail. Without the hot wire to the pump it will still not turn on with the key. I also have no power to the fuse unless I jump it. I Attempted to jump the pump with hot wire and try to start it but it will not give the same engine run result as the starter fluid does I have replaced the fuel pump relay, oilpressure switch,Plugs, wires, oil and Filter.. iam not a mechanic and iam severely Financially challenged due to the pandemic so taken her to the shop is not an option and I’m not able to work until I get this sucker fixed. Bottom line is I don’t know what my next step should be. Anyone have any suggestions cuz I need help.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the reply but I had the same thought and since have bought two. The first one being dead on hook up so had to walk back to autozone and get a replacement
 
1 - 3 of 3 Posts
Top