Chevy Corvette Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2003. It will not start, or even crank. It will not jump start, I even installed a new battery, still no good. Problem seemed to start when ignition key would not physically go into ignition lock. It now goes in lock, turns, but nothing. Is it a security issue? is there someting I can reset? Battery was dis-connected, then replaced. I am at a loss. Can someone please assist. Thanks
 

·
Registered
Joined
·
5,563 Posts
do you have any power to anything ?
 

·
Registered
Joined
·
2 Posts
  • Have you taken care of all recalls?
  • Does your battery have a good charge (even new batteries can be defective or drained)?
  • Battery terminals free of corrosion and properly secured?

Your steering column lock might be acting up. It's really common. Check out this thread:

digitalcorvettes[dot]com/forums/showthread.php?t=125651

My account is new so I can't post links so you'll need to change the [dot]com to ".com"
 

·
Registered
Joined
·
19 Posts
  • Have you taken care of all recalls?
  • Does your battery have a good charge (even new batteries can be defective or drained)?
  • Battery terminals free of corrosion and properly secured?

Your steering column lock might be acting up. It's really common. Check out this thread:

digitalcorvettes[dot]com/forums/showthread.php?t=125651

My account is new so I can't post links so you'll need to change the [dot]com to ".com"
 

·
Registered
Joined
·
19 Posts
I am having the same problem , help. 01 C5. I insert the key and nothing lights up or flickers like a dead battery. I replaced the battery after only 7 mts use, same result. The first time I replaced the battery I did not re- install the new battery until the next day. that is where this all started. had the car towed to dealer to check car, while getting the car off the tow truck the car just started fine. However the dealer said nothing was wrong with the car. No after 7 mts the same problem. Also while driving it cuts off and shows low power. worst the check eng light comes on but goes off after sitting for a few minutes. Can anyone help me as to where to go from here. the codes all show an h for history which also means it is ok now. My codes are AO-LDCM 2282H, 2284H, 2286H and u1064Hm, RDCM b2283H, 2285H2265H, and 28TCI C1278H. Please anyone pm me where to start.
to start the car I sometimes have to turn the key off and on a few times, but the dash doesn't all turn on as before just before i give it the full turn to the right.
Thanks
 

·
Registered
2013 Chevrolet Corvette 427
Joined
·
3 Posts
I am having the same problem , help. 01 C5. I insert the key and nothing lights up or flickers like a dead battery. I replaced the battery after only 7 mts use, same result. The first time I replaced the battery I did not re- install the new battery until the next day. that is where this all started. had the car towed to dealer to check car, while getting the car off the tow truck the car just started fine. However the dealer said nothing was wrong with the car. No after 7 mts the same problem. Also while driving it cuts off and shows low power. worst the check eng light comes on but goes off after sitting for a few minutes. Can anyone help me as to where to go from here. the codes all show an h for history which also means it is ok now. My codes are AO-LDCM 2282H, 2284H, 2286H and u1064Hm, RDCM b2283H, 2285H2265H, and 28TCI C1278H. Please anyone pm me where to start.

to start the car I sometimes have to turn the key off and on a few times, but the dash doesn't all turn on as before just before i give it the full turn to the right.


Here https://greencountryoffroad.com/parts/suspension/lift-kits-for-ford you can know more information about right battery for your car
Thanks
Does your "Security" display in the IPC go away when you insert the key?
 
1 - 6 of 6 Posts
Top