Chevy Corvette Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
293 Posts
Discussion Starter · #1 ·
My left brk. light does not work once in awhile. I have had all the ground wires checked and re-checked...One mach. told me it could be in my steering col..turn signal switch..I guess there is something that cancels your brake light so your turn signal will blink..But after i make my turn and the turn signal stops and i apply the brakes my left side brake light does not work...But it only happens once in awhile..Does anyone know about this? Is it my turn signal switch? Thanks guys for any your help PS: I have a hard time explaining myself at times....so i hope you can make sense out of what i just wrote.....lol Lawrence
 

· Registered
Joined
·
10,519 Posts
My left brk. light does not work once in awhile. I have had all the ground wires checked and re-checked...One mach. told me it could be in my steering col..turn signal switch..I guess there is something that cancels your brake light so your turn signal will blink..But after i make my turn and the turn signal stops and i apply the brakes my left side brake light does not work...But it only happens once in awhile..Does anyone know about this? Is it my turn signal switch? Thanks guys for any your help PS: I have a hard time explaining myself at times....so i hope you can make sense out of what i just wrote.....lol Lawrence

Well Lawrence, I would start by removing the bulb and check the socket. Make sure the spring is forcing the contacts against the bulb as quite often there is a buildup of junk inside the socket that prevents free movement.

When your turn signal works it just blinks the brake light on and off as it uses the same heavy filament. The taillights used the smaller filament.
 

· Registered
Joined
·
293 Posts
Discussion Starter · #3 ·
Thx for getting back to me Too Broke...So your saying there is nothing in my steering col. that can mess up my Brake lite's ? Like a bad turn signal switch? I have the conversion kit which now gives me two lites on each side. That would mean that both sockets would have to be bad. And they are only about a year and half old..
 

· Registered
Joined
·
10,519 Posts
Thx for getting back to me Too Broke...So your saying there is nothing in my steering col. that can mess up my Brake lite's ? Like a bad turn signal switch? I have the conversion kit which now gives me two lites on each side. That would mean that both sockets would have to be bad. And they are only about a year and half old..

Oh, I didn't know you had two on each side. And I don't know about the turn signal switch.....................
 

· Registered
Joined
·
10,519 Posts
Thx for getting back to me Too Broke...So your saying there is nothing in my steering col. that can mess up my Brake lite's ? Like a bad turn signal switch? I have the conversion kit which now gives me two lites on each side. That would mean that both sockets would have to be bad. And they are only about a year and half old..

Are you saying you have two brake lights and two turn signals on each side? Has it been working up until now? Please explain one more time exactly what is (or isn't) working.

Do this Lawrence. Take a battery-powered continuity tester and see if both of the sockets are grounded to the frame. Because it sounds to me like one of them isn't and is the cause of your problem.
 

· Registered
Joined
·
293 Posts
Discussion Starter · #6 ·
Yes i have that brake lite conver. kit which the old back up lite is removed and a new socket is put in that is a reg brk, running lite, and turn signal. And they also give you a new socket to replace the old outside lite as well... Four new socket and turn signal bulbs.. I have very hard time explaining things on paper....They have all been checked with the tester you memtioned and the ground also checked. The mach says that's not my problem...He said it must be in my turn signal switch in the steering colnum..?? I guess there is something in the switch that allows the turn signal to work and make the brk lite not stay on while you make a turn.. (shrug) I guess that sounds like it could be true. So if that part of the turn signal switch does not work correctly and after you make a turn does not cancel itself than the next time you step on the brk. the brake lite on that side still is being told not to work..?? I'm not sure i am explaining it right...Let me know what you think of what i have just written....
 

· Registered
Joined
·
10,519 Posts
Yes i have that brake lite conver. kit which the old back up lite is removed and a new socket is put in that is a reg brk, running lite, and turn signal. And they also give you a new socket to replace the old outside lite as well... Four new socket and turn signal bulbs.. I have very hard time explaining things on paper....They have all been checked with the tester you memtioned and the ground also checked. The mach says that's not my problem...He said it must be in my turn signal switch in the steering colnum..?? I guess there is something in the switch that allows the turn signal to work and make the brk lite not stay on while you make a turn.. (shrug) I guess that sounds like it could be true. So if that part of the turn signal switch does not work correctly and after you make a turn does not cancel itself than the next time you step on the brk. the brake lite on that side still is being told not to work..?? I'm not sure i am explaining it right...Let me know what you think of what i have just written....

What you just said makes perfectly good sense. I have never really thought about it but when you're making a turn and riding the brake pedal at the same time the turn signal DOES continue to blink. So there must be a disconnect in the switch that cuts off power to the brake light on THAT side (not both of them). The turn signal switches are easy to change...................maybe an hour of work. But they're pretty expensive as they can often cost as much as $75.
 

· Registered
Joined
·
293 Posts
Discussion Starter · #8 ·
Glad you could make sense of what i was trying to explain...Since i have had everything else checked i guess i will have to buy a new turn signal switch...Its the only possible thing it could be..I guess this is something that doesn't no bad very often cause i have never heard of anyone having this problem and i myself have owned many old cars in my day and never had this happen.....Thanks Too Broke
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top