Chevy Corvette Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Reads 0, sometimes hitting the reset button will give me a number. Where should I start looking for the fix?

First time Vette owner!

Thanks for any and all help!
 

·
Registered
Joined
·
291 Posts
Does everything else work on the instrument cluster? How about the range (miles to empty) display?

If your range display is reading properly, start looking at things that are specific to the MPG readout, like the instant/average switch.
It applies a ground to the dash to select the proper readout, if that ground connection is bad the display won't read correctly. Put a multimeter on the back of the switch and verify chassis ground is present and follows the switch position.

If the range display is also malfunctioning, how does the fuel level gauge look? Speedometer and tach?
Any problems with those should be investigated as the ECM uses those three inputs to calculate MPG and range.

Check the TACH connection at the distributor for corrosion too and make sure the TACH filter is grounded- noise on that input raises all sorts of oddball trouble with the ECM.
It can garble the memory the MPG and range displays use, which might explain either or both working temporarily when you press the "reset" switch- that switch clears the memory.
Also check the reset switch itself, it should only output a ground signal when it's depressed. If it's sending a reset (ground) signal to the memory all the time both the range and MPG readings will stay at zero, pressing it might interrupt that ground long enough to get a temporary reading. Temporarily pulling the connector off the switch should be a good test there.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thank You for the help!

It appears range, fuel everything else is working, only issue seems to be with instant / avg.....

I have thought the reset was sending a constant message...(short)

I think I will check that first. So what is the best way to gain access to it?.......
 

·
Registered
Joined
·
291 Posts
It appears range, fuel everything else is working, only issue seems to be with instant / avg.....
If the reset switch were bad the range display would likely keep resetting as well. Since yours is working, I'd still check the reset switch out, but I'm almost tempted to look at the instant/average toggle switch first.
Once you remove the trim around the center console you'll see how the switch panel comes out.
 

·
Registered
Joined
·
1,213 Posts
Thank You for the help!

It appears range, fuel everything else is working, only issue seems to be with instant / avg.....

I have thought the reset was sending a constant message...(short)

I think I will check that first. So what is the best way to gain access to it?.......
If i were you i wouldn't sweat it too much, those readings aren't very acurate to begin with. Drive on!
 

·
Registered
Joined
·
2 Posts
Reads 0, sometimes hitting the reset button will give me a number. Where should I start looking for the fix?

First time Vette owner!

Thanks for any and all help!
Everything I have read says to test the reset button for starters.
If you have not done so it is well worth spending the money for the shop manual and the second section for the electrical. It does not have enough pictorial displays so you can follow exact instructions nor does it have complete description for the procedures but it will give you a good starting place, if not complete instruction, almost every time.
 
1 - 6 of 6 Posts
Top