Chevy Corvette Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter · #1 ·
Transmission problems again. Shifter moves freely and car won't change out of gear. 1999 coupe with automatic transmission. I put the car up on stands and the linkage is still attached to the transmission. I have taken the console out of the car and have removed the shifter boot. Are there any diagrams out there that I can look at to see what might be causing the problem? I did find one part under the console that looks like a black plastic .22 caliber shell with a semi-circle head on top.
 

·
Premium Member
Joined
·
9,048 Posts
have someone move shifter while you are underneath looking at shift lever where cable attaches.. if it doesn t move, its the cable , if it does, its the trans and not going into gear...
 

·
Registered
Joined
·
5,563 Posts
having broken the cable before......it's probably the cable or more likely the cable housing
 

·
Premium Member
Joined
·
9,048 Posts
mine broke right in the cheap ars plastic connector at the trans lever.. made in China no doubt.. I made a new one, NOT PLASTIC and haven t had any trouble since
 

·
Registered
Joined
·
123 Posts
Discussion Starter · #7 ·
Cable it is....

Went to Ivan Leonard and spoke personally to the guy at the parts counter. He had the cable in stock and it was only $79.00. Big difference in in person price compared to over the phone price. The cable has a plastic cup that the shifter linkage fits into. It was broken and had fallen off of the shifter allowing the shifter to move freely. I put a plumbing repair rubber washer and a bonded metal and rubber cupped washer into the opening and taped them in place. Reinserted shifter linkage and put shifter back in place. Shifts fine for now. I will keep the cable in the car until I can get a chance to take it to the mechanic to have the new cable installed.
 

·
Registered
Joined
·
5,563 Posts
FYI : labor is a killer on that
 
1 - 9 of 9 Posts
Top