Chevy Corvette Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I just installed my BBK CAI the other day. No later than 24 hours my check engine light came on. Took it to Chevy and they came up with P0171 and P0174 errors and won't proceed any further to TS until I put my stock CAI back on. Am I the only one that puts CAI's on their Vette? I think not. So what kind of an issue do I have here or where can I go to by pass the light. I unhooked my pos battery cable but the check engine light came back on after about a hour of driving it again. I don't want to be out of 350 dollars for the new CAI, I wouldn't think you could sell a CAI as a company if it was going to cause errors. Any ideas?
 

·
Registered
Joined
·
286 Posts
Those codes are telling you that bank 1 and 2 are lean. What you need to do is get the car tuned with the new CAI. Normally the CAI's that require aftermarket tuning will tell you upfront that it is needed but apparently that is not the case with this one. You can either look up a canned tune like from Livernois or some other aftermarket tuner that has set tunes for intakes or you can take it to a dyno shop and have them do a full custom tune. But if you're going to go through that much trouble I say go ahead and add some long tubes an exhaust and maybe a cam lol but hey, that is just my way of justifying it :thumbsup3:

BTW, what part of VA are you in?
 

·
Registered
Joined
·
1,564 Posts
It is rare for a cold air unit to trip a code, but it can happen. Before getting a tune (which adds more power than CAI), check again for leaks. If you are lean enough to trip the SES codes, it is possible that then unmetered air is getting in. Did you touch or remove the MAF during the install? I'd make sure the MAF was put back in the correct direction if you removed it during the install, and that everything around the MAF and behind it is sealed and didn't come lose or get damaged during the install.

You can shoot starter fluid (ether) around the MAF area and see if you detect any increase in revs. Just don't do it on a heat soaked engine. ;)
 

·
Registered
Joined
·
4,197 Posts
I just installed an Airaid CAI on my 2012 grand sport,I have the same problem,exact same codes.I took off the Airaid system and put the OEM back on,the check engine light went out, I reinstalled the Airaid and a week later the CEL came back on,so I contacted the vendor and he said it may take about 200 miles or so for the computer to adjust to the new CAI. In the mean time I ordered a OBD 2 and plant to clear the codes and hope that it will eventually it will except the CAI. Keep in touch maybe one of us will solve this problem.
 

·
Registered
Joined
·
1,564 Posts
I remember people having problems with a particular brand of CAI a long time back, but I thought it was on cars w/o the card MAF. The CAI change the airflow pattern, so more air was bypassing the meter's wires.

In the LS1, the lean codes tripped when the trims were hitting their limit of adjustment, which was 25%. I don't know if it still uses that test, but someone with HPT or EFILive could read your LTRIMs and see where they are.
 

·
Registered
Joined
·
96 Posts
From what i understand, Unlike the C5s, the C6 LS2 and LS3 can not compensate for the extra air over the MAF with more fuel. Results being lean codes in both banks. Sorry to say the only fix is a custom tune, But on a good note, it is a great time to add a cat-back system, like the Corsa Sport and bring both mods together for a nice gain in HP.
 

·
Registered
Joined
·
12 Posts
I installed snake charmer CAI on my LS3. No problems for about a year than it started pulling lean codes. I diagnose the problem to the cheap rubber spacer between MAF and throttle body.Called the manufacturer and they sent me a replacement and it lasted a couple months. The codes were back remove it, been find ever since. To address your problem the lean codes are indicating you have air leak beyond the MAF. The MAF censor on LS3 will increase the fuel duration on the injectors to correct any increase air flow due to the CAI unless it can't measure it.
 

·
Registered
Joined
·
4,197 Posts
UPDATE: the distributor for Airaid sent me a new tube(the part from the filter to coupler) and it did the same thing. I bought a code reader and cleared the codes,if they return I will put the stock system back on.
 
1 - 9 of 9 Posts
Top