Chevy Corvette Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hey all need some help.... I was stuck in traffic the other day in my 03 daily driver that has 108K miles on it. Anyway, the temp gauge was going up and I decided to turn on the A/C unit to kick on the fans. Upon pushing the A/C button to turn on, the light indicator flashed a few times and the A/C never turned on.
I have tried several times since that afternoon, but always the same thing, the indicator light flashes about 4 times and the A/C never turns on.
Anybody have a thought about what is wrong with the unit???

Thanks for your suggestions/comments, as always you guys are the best help...
 

·
Registered
Joined
·
5,563 Posts

·
Smokin Vendor
Joined
·
612 Posts
After pulling the codes try hitting the mode button until the arrow shows blowing in your face and hit the outside or inside air, also move the temp to colder. Mine has acted up like that before and does clear up when do the mode button. Also this will happen if you have it on defrost setting.
 

·
Smokin Vendor
Joined
·
612 Posts
I just read in my manual that the a/c will be forced off at high coolant or oil temperatures. So if your running hot it wont be allowed to turn on. Have you ever changed your thermostate as seems to be acting up and have you flushed your cooling system as also needs this also check under the bottom to see if youve sucked up any plastic bags as vetts are bottom breathers. I believe your a/c is ok as is not being allowed to turn on and leads me to your thermostate again.
 
1 - 9 of 9 Posts
Top