Chevy Corvette Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Hi, hope you're all staying warm. My '90,a/t,all stock has 2 problems. I don't know if they're separate or possibly related. The 1st is the clicking sound(like a relay)from under the pass. side dash. The interior lights won't come on until the clicking stops. Pressing the brake or opening the hatch usually stops it. The 2nd is the service ABS light coming on. The vehicle rolls the required distance but the hydraulic assist does not kick in. The ABS light comes on, the dash lights will flicker continuously and the engine runs rough. Turning the key to 'run' position for a few seconds before starting sometimes helps. This problem happens most of the time but not all. Any suggestions would be greatly appreciated, TIA, Bob.
 

·
Registered
Joined
·
2,849 Posts
The 2nd is the service ABS light coming on. The vehicle rolls the required distance but the hydraulic assist does not kick in.
Could pull the ABS codes
ABS Codes:
Shorting pin "H" to pin "A" on the ALDL connector will cause the ABS light to flash ABS codes.
terminal H is next to G in the pic ( pre '90 shown )


 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
Thanks for info. will try asap. Does car have to running or key in 'run' position, or off? Any thoughts on the 'clicking' sound? I was going to pull fuses until it (hopefully)stopped to isolate if possible. Thank you again, the vette is in storage so it may be a bit before I get to it.
 
1 - 5 of 5 Posts
Top