Chevy Corvette Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
HI GUYS

I HAVE AN 85 VETTE AND ITS GETTING HARD TO START IT IS GETTING FIRE AND ITS GETTING GAS JUST A LITTLE HARD TO STAT WHEN ITS COLD SHOULD I GET A CAN OF CHOKE CLEANER AND SPRAY THE HECK OUT OF THE THROTTLE BODY IM OPEN TO SUGGESTIONS

THANK YOU FOR THE HELP
JEFF:thumbsup3:
 

·
Registered
Joined
·
797 Posts
We need more info, my diagnosis would be different from a car with 100k to a car with 10k. Could be a battery, could be plugs...does it fire right up when it starts or does it struggle to get to idle speed?
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
I got it to run

Hi Guys
I worked on my vette today and last night I think I found the problem I sprayed the heck out of the trottle body and put some cleaner in the tank took down the highway and blew the cobs out of it i think im haveing a battery problem or lose cabel to the starter it will fire up now with no probelems the car has 100.00 plus miles on it has new plugs wires ect

thanks for the input
Jeff
 

·
Registered
Joined
·
10,329 Posts
HI GUYS

I HAVE AN 85 VETTE AND ITS GETTING HARD TO START IT IS GETTING FIRE AND ITS GETTING GAS JUST A LITTLE HARD TO STAT WHEN ITS COLD SHOULD I GET A CAN OF CHOKE CLEANER AND SPRAY THE HECK OUT OF THE THROTTLE BODY IM OPEN TO SUGGESTIONS

THANK YOU FOR THE HELP
JEFF:thumbsup3:

When you say "it's getting a little hard to start" are you saying it spins over but takes an abnormally long time to fire off? And does it crank fast enough? It should crank at around 550-600 rpm or as fast as it would normally idle when warmed up. If it cranks slow it could be as simple as dirty battery cables or a weak starter.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top