Chevy Corvette Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
I recently joined the Corvette owners club by purchasing an 84. It has some minor issues here and there that I've been trying to resolve over the winter. Most recently I replaced the flasher unit and the drivers door lock switch. Since this has happened I am unable to start the car.

I have full power, when I turn the key to the crank position nothing from the starter, but I can hear the fuel pump relay click and a buzz sound for a couple of seconds.
I've checked all fuses, battery is new and fully charged, ECM wiring is all in place as is all under dahs wiring I can see.

I put a test light to the starter/solenoid battery terminal and have power, until the key is turned then I lose power and it stays powerless for a while.

I have found the wiring to the door locks for the factory security system (?) is disconnected in the drivers door. I think I've tripped something somewhere which is preventing power to the starter. All cables are tight. What would interupt the power from the battery to the starter solenoid and cause this loss of power?

I've also noticed that the security light on the dash flashes when the doors are open, but when they're closed it goes out. I believe this used to flash when the doors were closed previously.

Thanks in advance for any assistance. I'm lost here, and the car was running & starting perfectly prior to me replacing the flasher and door lock switch.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
I should also mention I read elsewhere that there is a door lock security relay, or something that can be removed from the vehicle. If this is the case how do I remoce it? Thanks.
 

·
Registered
Joined
·
9,695 Posts
I recently joined the Corvette owners club by purchasing an 84. It has some minor issues here and there that I've been trying to resolve over the winter. Most recently I replaced the flasher unit and the drivers door lock switch. Since this has happened I am unable to start the car.

I have full power, when I turn the key to the crank position nothing from the starter, but I can hear the fuel pump relay click and a buzz sound for a couple of seconds.
I've checked all fuses, battery is new and fully charged, ECM wiring is all in place as is all under dahs wiring I can see.

I put a test light to the starter/solenoid battery terminal and have power, until the key is turned then I lose power and it stays powerless for a while.

I have found the wiring to the door locks for the factory security system (?) is disconnected in the drivers door. I think I've tripped something somewhere which is preventing power to the starter. All cables are tight. What would interupt the power from the battery to the starter solenoid and cause this loss of power?

I've also noticed that the security light on the dash flashes when the doors are open, but when they're closed it goes out. I believe this used to flash when the doors were closed previously.

Thanks in advance for any assistance. I'm lost here, and the car was running & starting perfectly prior to me replacing the flasher and door lock switch.

It sounds like one of your battery cables isn't making a good connection at the battery. Take the cables off and thoroughly clean the connections and then try it again.
 
1 - 3 of 3 Posts
Top