Chevy Corvette Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi all,
Just wanted to ask if anyone could advise. My instrument panel is not working at all. The gauges, DIC and warning lights including the cluster. Back light are dead. My HUD is working but the rest is dead. Any ideas where to start looking?

Regards

Denis
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
Well there has been 39 views but no one has any advise and it looks like no other corvette owner has had a problem with the instrument panel cluster. Can' t believe that? Come on guys help out a fellow corvette owner!!!
 

·
Premium Member
Joined
·
9,048 Posts
Sorry no one replied. I am not familiar with C6 issues but I would start at the fuse box and connections. Have you tried pulling trouble codes?.. But In my experience with C5s, when the Cluster goes, it goes.. There are companies that rebuild them, and of course replacements . $$$$.. Sorry I cannot help with this.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Thanks Fishslayer for the reply. The problem is I live on the other side of the pond where there are minimal Chevy garages and even fewer cluster repairers. I will have to try and find the fault and fix it. I just thought there may have been others who had had the same problem and could give me a starting point.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Hi Fishslayer,
I have bitten the bullet and ordered one from eBay. Just have to wait till it arrives this side of the pond (UK) to see it was the cluster. I thought corvettes were bomb- proof cars where nothing goes wrong. Only had it six weeks and the expense has started.
 

·
Premium Member
Joined
·
9,048 Posts
lol... NOT BOMB-PROOF ... The electronics are the Achilles heel on these things. The engines and transmissions are tough ..good luck, let us know how it turns out
 

·
Registered
Joined
·
1 Posts
Hi Fishslayer,
I have bitten the bullet and ordered one from eBay. Just have to wait till it arrives this side of the pond (UK) to see it was the cluster. I thought corvettes were bomb- proof cars where nothing goes wrong. Only had it six weeks and the expense has started.
Hello I too had a gauge cluster problem on my 05 coupe. I ended up getting a used one that works great but the mileage is way off 55k on original now 96k on used one. It works fine so I might just leave it the way it is. Dealer wanted a crazy amount of money for a rebuilt one plus I had to leave the car for 2-3 weeks.
 
1 - 8 of 8 Posts
Top