Chevy Corvette Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I jsut recently purchased a 1979 Corvette with the L-48 engine. It is a California car and starts fine and idles at 1300 RPM till warmed up. At this point the idle drops below 500 RPM and the engine stalls. I have checked most vacuum lines, put in a new air filter and fuel filter. What could the problem be?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 · (Edited)
Wont Idle

I had my brother in law adjust the idle (on the drivers side) over the Xmas holidays while I kept the RPM's up. This seemed to help for a while, now it's back to the initial problem. Note, I also added Sea Foam to the gas tank which I hoped would clean the carb. This car sat in storage for 12 years and the owner took it out of storage and started working on it about 2 years ago.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Wont Idle

Thanks for your responses. I kinda of figured that the carb. has issues. This is my fourth vette. I had a 74, 70 and 80 prior to this. The 74 and 70had a 454. The 80 had the L-82. I never had problems with any of he previious cars but the 79 I just bought has a ton of problems (mainly vacuum and electrical). I'll probably just buy a rebuilt carb and go from there. Summit sells a rebuilt for $299 which I hope will work on this car since it is originally a California vehicle.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top