Chevy Corvette Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
241 Posts
Discussion Starter #1
I finally decieded to get the tach working properly, so I pulled it out , replaced both curcit boards and put it back together. I worked fine. When I was out on the expressway I noticed when I punched it to pass, the tach jumped into the red zone, I backed off, and it can back down. Seemed to be running 3000-3500 rpm at 65-70.

I am thinking that this might be a tranny problem (Slipping) and not the tach. When I drive around town, it seems to act as it should, alhtought at 1300 at idle. I assume I need to pull the needle off again and reset it 500rpm lower.

Is this a tranny or tach issue. By the way, all the board where replaced with new.

On another note, I pulled the speedo and cleaned it up, worked fine, then a few days later it drifted to starting point of 110 mph, I am thinking it just slippped and I was going to pull it, reset it and add a little locktite to it when I reset it at 0.
 

·
Registered
Joined
·
32 Posts
The tach running at 3000-3500 rpm at 70mph would not be unusual if you are running a 3.73 or 3.90 rearend gear. As for the speedo, have you inspected the drive cable?
 

·
Registered
Joined
·
241 Posts
Discussion Starter #4
After running it for a while, when I punch it, the tach goes way into redline and if I let up will drop back to say 3000 rpm, if I punch it again, it goes into redline and as soon as I let up back down.

If I just accelrate reasonably and let up, it drops and rises about 1000 rpm

any other suggestions, I hope its not the tranny but sure sounds like its slipping.

I got the speedo working, the needle was replaced and was lose.
 

·
Registered
Joined
·
523 Posts
If the RPM jumps with no big jump in speed, then I'll go with a slipping trans. What's the fluid look/smell like?

Before you go pulling needles and resetting them, I'd verify the tach with an external hand held one.
 

·
Registered
Joined
·
241 Posts
Discussion Starter #8
Any other ideas?
It actually only drops 500 rpm whe I let up, when I accelerate reasonably, it only has the 500 rpm drop when I let up, but when I floor it, it kicks down and can get into redline, then when I let up drops 1000-2000 rpms
 

·
Registered
Joined
·
584 Posts
Any other ideas?
It actually only drops 500 rpm whe I let up, when I accelerate reasonably, it only has the 500 rpm drop when I let up, but when I floor it, it kicks down and can get into redline, then when I let up drops 1000-2000 rpms
have you checked the trans.? other problem could be the brass gear on the distributer ( theres not to many things that could mess with the RPM's)
 

·
Registered
Joined
·
9,695 Posts
With 3.08 gears you should see around 2500-2600 rpm at 60 mph. With 3.54 gears you should see around 2800-2900 rpm at 60 mph. That's assuming you have stock diameter tires.
 
1 - 10 of 10 Posts
Top