Window Motor Problems - SmokinVette.com Forums
SmokinVette.com Home
  • Corvette Forum
  • Login to Corvette Forums
  • SmokinVette.com
  • About SmokinVette.com
  • Corvette Forum
  • Corvette Gallery
  • Corvette Parts
  • Corvette Yellow Pages
SmokinVette.com Forums : Corvette Forums : C3 Corvette Forums : C3 Corvette General Discussion : Window Motor Problems
C3 Corvette General Discussion
1968 - 1982 Corvettes Sponsored by
XS Power

Reply
Thread Tools Search this Thread Display Modes
Old 06-19-2013, 08:03 AM   #1
ssclassics
Smokin Member
 
Join Date: Jun 2013
Posts: 7
Default Window Motor Problems

I have a 1981 Vette. I have a problem with the passenger side window. I can not get the motor to work up or down. I had installed a new motor about 6 months ago and it worked fine but was extremely fast. Then it just stopped working. I took it back and ordered another one. Put it in and nothing. So, I took that one back and got another one. NOTHING. I have power at the pigtail. I even put an extra ground wire on the motor housing to the door frame to make sure I was getting a good ground. Does an 81 have a window motor regulator under the console like the 78 and older does? What could the problem be?
ssclassics is offline  
Send a Private Message Reply With Quote
Old 06-19-2013, 08:23 AM   #2
fishslayer143@yahoo.com
Smokin 5000HP+ Posting Maniac
 
Join Date: Jun 2009
Location: New Iberia LA
Posts: 8,097
Default

are you sure its not jammed ? theres a front roller that is prone to come off and wedge the glass ..can you move the glass up and down?
fishslayer143@yahoo.com is offline   Send a Private Message Reply With Quote
Old 06-19-2013, 08:28 AM   #3
ssclassics
Smokin Member
 
Join Date: Jun 2013
Posts: 7
Default

No I can not move the window up or down with the motor installed. Yes I can with it out.
ssclassics is offline   Send a Private Message Reply With Quote
Old 06-19-2013, 09:20 AM   #4
ssclassics
Smokin Member
 
Join Date: Jun 2013
Posts: 7
Default

Any ideas???
ssclassics is offline   Send a Private Message Reply With Quote
Old 06-19-2013, 10:45 AM   #5
Lethal Tendencies
Agent
 
Lethal Tendencies's Avatar
 
Join Date: Mar 2007
Location: Illinois
Posts: 5,121
Default

can you hear the motor trying to run? Try doing a continuity test on your switch?
__________________


'77 coupe(sold) '86 coupe(sold)'98 vert (sold) '00 coupe( sold ) '85 coupe( sold ) '75 Vert ( Last one ? )

http://lethalvette.blogspot.com/
Lethal Tendencies is offline   Send a Private Message Reply With Quote
Old 06-19-2013, 01:23 PM   #6
ssclassics
Smokin Member
 
Join Date: Jun 2013
Posts: 7
Default

No, the motor does not even try to run. Is the a relay under the console like in a 78 and older?
ssclassics is offline   Send a Private Message Reply With Quote
Old 06-19-2013, 01:50 PM   #7
toobroketoretire
Smokin 5000HP+ Posting Maniac
 
toobroketoretire's Avatar
 
Join Date: Feb 2009
Location: Dunlap, California
Posts: 8,932
Default

Quote:
Originally Posted by ssclassics View Post
I have a 1981 Vette. I have a problem with the passenger side window. I can not get the motor to work up or down. I had installed a new motor about 6 months ago and it worked fine but was extremely fast. Then it just stopped working. I took it back and ordered another one. Put it in and nothing. So, I took that one back and got another one. NOTHING. I have power at the pigtail. I even put an extra ground wire on the motor housing to the door frame to make sure I was getting a good ground. Does an 81 have a window motor regulator under the console like the 78 and older does? What could the problem be?

Over the years I have found power window problems are usually caused by bad connections at the rocker switch. As far as the relay under the console goes I believe the same relay was used for all the C3's. The relay has an overheat switch that will stop it from working for several minutes any time it gets overheated. But before ripping everything apart check the rocker switch and make sure the connections are making a good contact with the switch.
toobroketoretire is offline   Send a Private Message Reply With Quote
Old 06-29-2013, 08:53 AM   #8
JOSE'S 79
Smokin 100HP Club
 
Join Date: Jul 2010
Location: LI N.Y.
Posts: 130
Default

did you try running the motor before you installed it?
JOSE'S 79 is offline   Send a Private Message Reply With Quote
Old 06-29-2013, 06:13 PM   #9
C3blackvette
Smokin 200HP Club
 
C3blackvette's Avatar
 
Join Date: Dec 2010
Location: NY
Posts: 209
Default

With my 1980, the power windows have been a source of buying aspirin since I got the vette.
Put power to the window motor and confirm it works. Use a voltmeter and check the harness connector plug for power. Be careful not to damage the connectors in the plug when you insert the test leads. Don't go from one of the leads in the plug to a ground on the car, keep the 2 test leads on the plug. When you work the switch, a digital voltmeter will read power if the switch is working. When the meter shows a negative symbol in-front of the number, it means the polarity reversed for the window to go in the other direction. If you don't get correct power at the plug, you need to check the wiring to the switch.
C3blackvette is offline   Send a Private Message Reply With Quote
Old 06-29-2013, 06:37 PM   #10
sting66ray
Smokin 750HP Supercharged Club
 
sting66ray's Avatar
 
Join Date: Aug 2010
Location: Vetteville, FL
Posts: 815
Default

This is a power window wiring diagram for a '75. Maybe there are similarities. Hope it helps.

sting66ray is offline   Send a Private Message Reply With Quote
Sponsored Links
Advertisement
 
Reply

Share This Thread
  • Submit Thread to Digg
  • Submit Thread to del.icio.us
  • Submit Thread to Facebook
  • Submit Thread to StumbleUpon
  • Submit Thread to MySpace
  • Submit Thread to Twitter
  • Submit Thread to Google
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -8. The time now is 08:51 AM. Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2006-2009 © SmokinVette.Com