Ignition timing - not sure what to do next.... - SmokinVette.com Forums
SmokinVette.com Home
  • Corvette Forum
  • Login to Corvette Forums
  • SmokinVette.com
  • About SmokinVette.com
  • Corvette Forum
  • Corvette Gallery
  • Corvette Parts
  • Corvette Yellow Pages
SmokinVette.com Forums : Corvette Forums : C3 Corvette Forums : C3 Tech & Performance : Ignition timing - not sure what to do next....
C3 Tech & Performance

Reply
Thread Tools Search this Thread Display Modes
Old 01-13-2013, 03:42 PM   #1
Haggisbash
Smokin Member
 
Join Date: Sep 2012
Location: New Zealand
Posts: 24
Default Ignition timing - not sure what to do next....

Hi, looking for suggestions, I have just removed the Mallory dual point distributor from my 350 and replaced it with an original single point model. Reason for this is that the Mallory had no vacuum advance and I figured after reading up on the forum that for street use the motor would perform better with vacuum advance (which it does). An issue though, sometimes when I step on the gas after coasting the motor will give a single cough and then start to pull normally, this problem diminished a lot when I changed out the two heavy springs that came with the distributor for a light and medium spring, the advance is now all in around 2500 RPM and approx 35 deg BTDC with the vac disconnected and plugged. The motor winds over easily enough and there is no sign of detonation. Idle mixture is set at highest vac which was 17 In Hg.
Haggisbash is offline  
Send a Private Message Reply With Quote
Old 01-17-2013, 04:30 AM   #2
toobroketoretire
Smokin 5000HP+ Posting Maniac
 
toobroketoretire's Avatar
 
Join Date: Feb 2009
Location: Dunlap, California
Posts: 8,857
Default

Quote:
Originally Posted by Haggisbash View Post
Hi, looking for suggestions, I have just removed the Mallory dual point distributor from my 350 and replaced it with an original single point model. Reason for this is that the Mallory had no vacuum advance and I figured after reading up on the forum that for street use the motor would perform better with vacuum advance (which it does). An issue though, sometimes when I step on the gas after coasting the motor will give a single cough and then start to pull normally, this problem diminished a lot when I changed out the two heavy springs that came with the distributor for a light and medium spring, the advance is now all in around 2500 RPM and approx 35 deg BTDC with the vac disconnected and plugged. The motor winds over easily enough and there is no sign of detonation. Idle mixture is set at highest vac which was 17 In Hg.

Under deceleration vacuum can go as high as 25 Hg which can pull oil past the piston rings and thru the intake valve guide. I don't know the condition of your engine but if it has a lot of miles the high vacuum could be coating the plugs with some oil which could cause a momentary missing condition. When running a vacuum advance shoot for 50-52 degrees total advance at cruising speeds. And then don't exceed 38 degrees mechanical advance. Remember, the vacuum advance doesn't work at all under full power and is there just for better fuel mileage.
toobroketoretire is offline   Send a Private Message Reply With Quote
Old 01-17-2013, 04:43 AM   #3
fishslayer143@yahoo.com
Smokin 5000HP+ Posting Maniac
 
Join Date: Jun 2009
Location: New Iberia LA
Posts: 8,024
Default

your momentary cough may not be timing related.. check function of your carbs accelerator pump.. it should spray fuel at the slightest movement of the throttle
fishslayer143@yahoo.com is offline   Send a Private Message Reply With Quote
Old 01-19-2013, 03:18 PM   #4
Haggisbash
Smokin Member
 
Join Date: Sep 2012
Location: New Zealand
Posts: 24
Default

Seems it was an accelerator pump/idle mixture issue. I reset the acc pump to instructions I found online and also reset the idle mixture which seemed to have gone lean since adding the vacuum equipped distributor. Pick up from idle or over run is much improved and there is now very little popping from the exhaust on over run. Next mission is to decide whether to change out the Edelbrock torker manifold which I read are best suited for 2500 - 5500 rpm for say a performer EPS or performer 2101 both of which I can get for less $$ than a stock alloy manifold. Any thoughts suggestions as to best pick for cruising low rpm use. 2500 rpm is the open road speed limit here so a manifold biased above this range is not best suited for my use of the car. I need my drivers licence for work and if you get pulled for 140kmh plus here they will suspend your licence on the spot and impound your vehicle for a month as well :-(
Haggisbash is offline   Send a Private Message Reply With Quote
Old 01-19-2013, 06:29 PM   #5
fishslayer143@yahoo.com
Smokin 5000HP+ Posting Maniac
 
Join Date: Jun 2009
Location: New Iberia LA
Posts: 8,024
Default

Quote:
Originally Posted by Haggisbash View Post
Seems it was an accelerator pump/idle mixture issue. I reset the acc pump to instructions I found online and also reset the idle mixture which seemed to have gone lean since adding the vacuum equipped distributor. Pick up from idle or over run is much improved and there is now very little popping from the exhaust on over run. Next mission is to decide whether to change out the Edelbrock torker manifold which I read are best suited for 2500 - 5500 rpm for say a performer EPS or performer 2101 both of which I can get for less $$ than a stock alloy manifold. Any thoughts suggestions as to best pick for cruising low rpm use. 2500 rpm is the open road speed limit here so a manifold biased above this range is not best suited for my use of the car. I need my drivers licence for work and if you get pulled for 140kmh plus here they will suspend your licence on the spot and impound your vehicle for a month as well :-(
I thought that was the problem from your description.. glad you got it cleared up..as to manifolds, the Edelbrock Performer is an excellent choice for your driving ..that Torker is better suited for hi-revving,big cam/big gear cars
fishslayer143@yahoo.com is offline   Send a Private Message Reply With Quote
Old 02-17-2013, 10:53 PM   #6
Haggisbash
Smokin Member
 
Join Date: Sep 2012
Location: New Zealand
Posts: 24
Default

Performer EPS fitted but found that the air filter was stopping the hood from closing. Seems I have an old 13.5" drop base air cleaner that is no longer available. I compared this to a new 14" one and found there was about a 1/4" - 3/8" difference in height. I modified the old one to drop it to the same height and all good. Gas milage seems to have improved a little and the engine pulls better at low rpm so more drivable:-) So std dist and better manifold have been money well spent for what I use the car I think.
Haggisbash is offline   Send a Private Message Reply With Quote
Old 02-18-2013, 02:40 AM   #7
fishslayer143@yahoo.com
Smokin 5000HP+ Posting Maniac
 
Join Date: Jun 2009
Location: New Iberia LA
Posts: 8,024
Default

glad it worked out for you..the Torker was just not suited to your car or driving habits.. now enjoy
fishslayer143@yahoo.com is offline   Send a Private Message Reply With Quote
Sponsored Links
Advertisement
 
Reply

Share This Thread
  • Submit Thread to Digg
  • Submit Thread to del.icio.us
  • Submit Thread to Facebook
  • Submit Thread to StumbleUpon
  • Submit Thread to MySpace
  • Submit Thread to Twitter
  • Submit Thread to Google
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -8. The time now is 12:35 AM. Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2006-2009 © SmokinVette.Com