lumbar support - SmokinVette.com Forums
SmokinVette.com Home
  • Corvette Forum
  • Login to Corvette Forums
  • SmokinVette.com
  • About SmokinVette.com
  • Corvette Forum
  • Corvette Gallery
  • Corvette Parts
  • Corvette Yellow Pages
SmokinVette.com Forums : Corvette Forums : C4 Corvette Forums : C4 Corvette General Discussion : lumbar support
C4 Corvette General Discussion
1984 - 1996 Corvettes

Reply
Thread Tools Search this Thread Display Modes
Old 12-12-2012, 03:52 PM   #1
jaybird96
Smokin Member
 
Join Date: Oct 2012
Location: paducah ky
Posts: 3
Default lumbar support

where can I get the schematics for install and removal of motor and pump to the lumbar support on the driver side of my '96 c4?
jaybird96 is offline  
Send a Private Message Reply With Quote
Old 12-12-2012, 05:36 PM   #2
mat helm
Smokin 1000HP Twin Turbo Club
 
mat helm's Avatar
 
Join Date: Jun 2010
Location: NC
Posts: 1,402
Default

http://www.smokinvette.com/corvettef...ad.php?t=56309
mat helm is offline   Send a Private Message Reply With Quote
Old 12-14-2012, 09:43 PM   #3
vette82forme
Smokin 100HP Club
 
Join Date: Sep 2012
Location: yucaipa,ca
Posts: 182
Default

If it is like a 1990 you remove the lower seat cushion and the pump is that rectangular looking black box thing. 2 screws secure it. Hope that helps.

vette82forme is offline   Send a Private Message Reply With Quote
Old 12-15-2012, 07:56 AM   #4
DRMZO7
Smokin 100HP Club
 
DRMZO7's Avatar
 
Join Date: Dec 2007
Location: Sonoma Ca
Posts: 153
Default

IIRC the 95-96 pumps are the same. It's under the pass/side seat cushion, held in by a clamp with 1 rivet.

Does your pump operate?
DRMZO7 is offline   Send a Private Message Reply With Quote
Old 01-29-2013, 11:58 AM   #5
jaybird96
Smokin Member
 
Join Date: Oct 2012
Location: paducah ky
Posts: 3
Default

yes this helps thank you
jaybird96 is offline   Send a Private Message Reply With Quote
Old 01-29-2013, 11:59 AM   #6
jaybird96
Smokin Member
 
Join Date: Oct 2012
Location: paducah ky
Posts: 3
Default

no the pump is not working
jaybird96 is offline   Send a Private Message Reply With Quote
Old 01-29-2013, 02:46 PM   #7
vetteoz
Smokin 2500HP Pro Road Racer
 
Join Date: Jan 2009
Posts: 2,849
Default

Quote:
Originally Posted by jaybird96 View Post
no the pump is not working
Motor not running or motor running but not pumping air?
__________________
"Being able to "think outside the box" presupposes you were able to think in it." --Bob Lutz
vetteoz is offline   Send a Private Message Reply With Quote
Sponsored Links
Advertisement
 
Reply

Share This Thread
  • Submit Thread to Digg
  • Submit Thread to del.icio.us
  • Submit Thread to Facebook
  • Submit Thread to StumbleUpon
  • Submit Thread to MySpace
  • Submit Thread to Twitter
  • Submit Thread to Google
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -8. The time now is 11:00 AM. Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2006-2009 © SmokinVette.Com