radiator hose hot and cold - SmokinVette.com Forums
SmokinVette.com Home
  • Corvette Forum
  • Login to Corvette Forums
  • SmokinVette.com
  • About SmokinVette.com
  • Corvette Forum
  • Corvette Gallery
  • Corvette Parts
  • Corvette Yellow Pages
SmokinVette.com Forums : Corvette Forums : C4 Corvette Forums : C4 Corvette General Discussion : radiator hose hot and cold
C4 Corvette General Discussion
1984 - 1996 Corvettes

Reply
Thread Tools Search this Thread Display Modes
Old 11-09-2012, 12:50 PM   #1
prostreeter
Smokin 100HP Club
 
prostreeter's Avatar
 
Join Date: Feb 2008
Location: ny
Posts: 152
Default radiator hose hot and cold

have a 96 vette lt1 motor in 84 pickup, all hooked up with reverse flow. my lower hose is always cold motor runs great never overheating is cold hose normal? heater and everything good.
prostreeter is offline  
Send a Private Message Reply With Quote
Old 11-09-2012, 01:42 PM   #2
crossflag
Smokin 400HP Club
 
crossflag's Avatar
 
Join Date: Sep 2010
Location: Lebanon,Pa.
Posts: 441
Default

What does the temp gauge read? With the rad. cap off and engine warm do you see a flow?
__________________
Wrap ur Azz in Fiberglass
crossflag is offline   Send a Private Message Reply With Quote
Old 11-09-2012, 03:12 PM   #3
prostreeter
Smokin 100HP Club
 
prostreeter's Avatar
 
Join Date: Feb 2008
Location: ny
Posts: 152
Default

hate to sound dumb, temp gauge is 180 approx. where is rad.cap on reverse flow rad????????? thanks

Last edited by prostreeter; 11-09-2012 at 03:15 PM.
prostreeter is offline   Send a Private Message Reply With Quote
Old 11-09-2012, 05:06 PM   #4
crossflag
Smokin 400HP Club
 
crossflag's Avatar
 
Join Date: Sep 2010
Location: Lebanon,Pa.
Posts: 441
Default

If the motors running temp is 180 thats good. Drive it and enjoy
__________________
Wrap ur Azz in Fiberglass
crossflag is offline   Send a Private Message Reply With Quote
Old 11-09-2012, 05:14 PM   #5
vetteoz
Smokin 2500HP Pro Road Racer
 
Join Date: Jan 2009
Posts: 2,849
Default

Quote:
Originally Posted by prostreeter View Post
hate to sound dumb, where is rad.cap on reverse flow rad?????????
Where ever you put it , you don't state how you plumbed the system.
Are you using the stock pickup radiator or a Vette style radiator with the remote coolant bottle.

Reverse flow only affects the direction the coolant flows
__________________
"Being able to "think outside the box" presupposes you were able to think in it." --Bob Lutz
vetteoz is offline   Send a Private Message Reply With Quote
Old 11-09-2012, 10:21 PM   #6
twistedcherokee
Smokin 300HP Club
 
twistedcherokee's Avatar
 
Join Date: Oct 2008
Location: Falcon Co
Posts: 398
Default

Are you talking about a reverse rotation water pump? Normally a cold lower hose means that your thermostat is not opening. If your temp sensor is not in coolant, it may not be reading properly. Good luck

Toby
twistedcherokee is offline   Send a Private Message Reply With Quote
Old 11-10-2012, 02:50 AM   #7
vetteoz
Smokin 2500HP Pro Road Racer
 
Join Date: Jan 2009
Posts: 2,849
Default

Quote:
Originally Posted by twistedcherokee View Post
Are you talking about a reverse rotation water pump?
Reverse rotation pump only spins the opposite way , coolant flow through engine is still the same
Gen II LT1 is reverse flow through the block ; not the pump.
Coolant goes to heads first as opposed to the block first as with all Gen I SBC's
Also in stock LT1setup the coolant flow through the radiator is reversed
The thermo outlet goes to the bottom of the radiator and cool coolant goes back to engine from the top
Makes no difference .
My Gen 1 Camaro with a LT1 has the radiator hoses connected the conventional way; hot to top and cool from bottom
__________________
"Being able to "think outside the box" presupposes you were able to think in it." --Bob Lutz
vetteoz is offline   Send a Private Message Reply With Quote
Old 11-10-2012, 02:55 AM   #8
crossflag
Smokin 400HP Club
 
crossflag's Avatar
 
Join Date: Sep 2010
Location: Lebanon,Pa.
Posts: 441
Default

Quote:
Originally Posted by twistedcherokee View Post
Are you talking about a reverse rotation water pump? Normally a cold lower hose means that your thermostat is not opening. If your temp sensor is not in coolant, it may not be reading properly. Good luck

Toby
True but he stated the heater worked fine. Im thinking it has a 180 thermostat.
__________________
Wrap ur Azz in Fiberglass
crossflag is offline   Send a Private Message Reply With Quote
Sponsored Links
Advertisement
 
Reply

Share This Thread
  • Submit Thread to Digg
  • Submit Thread to del.icio.us
  • Submit Thread to Facebook
  • Submit Thread to StumbleUpon
  • Submit Thread to MySpace
  • Submit Thread to Twitter
  • Submit Thread to Google
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -8. The time now is 08:50 PM. Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2006-2009 © SmokinVette.Com