Recall - SERVICE ACTIVE HANDLING SYSTEM - SmokinVette.com Forums
SmokinVette.com Home
  • Corvette Forum
  • Login to Corvette Forums
  • SmokinVette.com
  • About SmokinVette.com
  • Corvette Forum
  • Corvette Gallery
  • Corvette Parts
  • Corvette Yellow Pages
SmokinVette.com Forums : Corvette Forums : C6 Corvette Forums : C6 Corvette General Discussion : Recall - SERVICE ACTIVE HANDLING SYSTEM
C6 Corvette General Discussion
2005 + Corvettes Sponsored by
B&M Racing

Reply
Thread Tools Search this Thread Display Modes
Old 05-03-2010, 05:20 PM   #1
biggulp
Smokin 500HP Club
 
biggulp's Avatar
 
Join Date: Dec 2009
Location: Norco
Posts: 676
Default Recall - SERVICE ACTIVE HANDLING SYSTEM

Anyone have any insight on this?

http://www-odi.nhtsa.dot.gov/recalls...search&summary
biggulp is offline  
Send a Private Message Reply With Quote
Old 05-03-2010, 06:12 PM   #2
Pappytinker
Smokin 2500HP Pro Road Racer
 
Pappytinker's Avatar
 
Join Date: Nov 2008
Location: Limbo, USA
Posts: 2,799
Default

Quote:
Originally Posted by biggulp View Post
Sounds like the NHTSA site has the story. I have seen numerous posts on this and on the other Forum regarding the problem. It sounds like enough people have reported the problem for a recall to have been issued.
Pappytinker is offline   Send a Private Message Reply With Quote
Old 05-03-2010, 06:40 PM   #3
dbradley
Smokin 100HP Club
 
Join Date: Sep 2009
Location: Sapulpa OK
Posts: 141
Default

Got 'the letter' today. I HATE to even think of taking it to a dealer. They'd probably get someone off the wash rack to try to fix it. Probably have a look myself to make sure the connectors are good and secure.
dbradley is offline   Send a Private Message Reply With Quote
Old 05-04-2010, 06:32 AM   #4
BUBBA
Smokin 1000HP Twin Turbo Club
 
BUBBA's Avatar
 
Join Date: Feb 2008
Location: Key West
Posts: 1,927
Question

Quote:
Originally Posted by Pappytinker View Post
Sounds like the NHTSA site has the story. I have seen numerous posts on this and on the other Forum regarding the problem. It sounds like enough people have reported the problem for a recall to have been issued.
How does that work? Rather how many people's complaints need to be received before the government will step in and issue recall?
__________________
Whats Hiding in Bubba's garage?

2007 Indy 500 Pace Car - 2240 miles
2001 C5 6 Speed Corvette - 96,000 miles
2003 Dodge Ram Pickup - 54,000 miles
1984 C4 Corvette - 68,000 miles - SOLD and Missed
BUBBA is offline   Send a Private Message Reply With Quote
Old 07-14-2010, 12:39 PM   #5
Gunslinger
Smokin Member
 
Gunslinger's Avatar
 
Join Date: May 2010
Location: So Cal
Posts: 40
Default

I had the recall service done on June 15th, and a month later the "Service active handling system" message reappeared on the DIC. It reappeared three times over the weekend so I brought it back to the dealer. They showed no codes when they hooked it up and are not sure what to do with it now. This is disturbing!!
Gunslinger is offline   Send a Private Message Reply With Quote
Old 07-15-2010, 10:52 AM   #6
Rock*Star
Smokin 50HP Club
 
Join Date: Jan 2009
Location: Mobile, Alabama
Posts: 52
Default

Quote:
Originally Posted by Gunslinger View Post
I had the recall service done on June 15th, and a month later the "Service active handling system" message reappeared on the DIC. It reappeared three times over the weekend so I brought it back to the dealer. They showed no codes when they hooked it up and are not sure what to do with it now. This is disturbing!!
Do they still have the car?
Rock*Star is offline   Send a Private Message Reply With Quote
Old 07-15-2010, 12:20 PM   #7
Gunslinger
Smokin Member
 
Gunslinger's Avatar
 
Join Date: May 2010
Location: So Cal
Posts: 40
Default

Quote:
Originally Posted by Rock*Star View Post
Do they still have the car?
I have the car back. I'm waiting for them to get their data recorder so they can install it in my Vette. I haven't had any of the braking issues, just the dash indicating their is a problem....
Gunslinger is offline   Send a Private Message Reply With Quote
Old 07-21-2010, 11:52 AM   #8
Gunslinger
Smokin Member
 
Gunslinger's Avatar
 
Join Date: May 2010
Location: So Cal
Posts: 40
Default

"Service Active Handling System" came on again today...fortunately I was about 2 blocks from the dealership. I drove straight over and they are checking it out now. Hopefully they can diagnose and fix the issue....

I'll keep y'all posted
Gunslinger is offline   Send a Private Message Reply With Quote
Old 07-22-2010, 09:46 AM   #9
Gunslinger
Smokin Member
 
Gunslinger's Avatar
 
Join Date: May 2010
Location: So Cal
Posts: 40
Default

Still not fixed. They disconnected the battery for a while thinking it would clear the system and reboot it I guess. Well it came on last night again......the saga continuues....
Gunslinger is offline   Send a Private Message Reply With Quote
Sponsored Links
Advertisement
 
Reply

Share This Thread
  • Submit Thread to Digg
  • Submit Thread to del.icio.us
  • Submit Thread to Facebook
  • Submit Thread to StumbleUpon
  • Submit Thread to MySpace
  • Submit Thread to Twitter
  • Submit Thread to Google
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -8. The time now is 11:37 PM. Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2006-2009 © SmokinVette.Com