VATS decoder module issues... - SmokinVette.com Forums
SmokinVette.com Home
  • Corvette Forum
  • Login to Corvette Forums
  • SmokinVette.com
  • About SmokinVette.com
  • Corvette Forum
  • Corvette Gallery
  • Corvette Parts
  • Corvette Yellow Pages
SmokinVette.com Forums : Corvette Forums : C4 Corvette Forums : C4 Corvette General Discussion : VATS decoder module issues...
C4 Corvette General Discussion
1984 - 1996 Corvettes

Reply
Thread Tools Search this Thread Display Modes
Old 07-31-2009, 07:30 PM   #1
Lowlevlflyer
Smokin 300HP Club
 
Join Date: Oct 2008
Location: Southern Oklahoma
Posts: 392
Default VATS decoder module issues...

Where can I find a new VATS decoder module? None of the usual catalogs seem to have it. I'm guessing this is a dealer only part?

I think mine has gone to seed. I've had a couple of VATS issues in the past where the car wouldnt crank. After taking the key out and letting it sit for a few minutes, the system reset and the car started with no problems. Last night, when I got home I parked the car in front of the garage. about 40 min. later it started to rain, so I went out to move it into the garage. Put the key in and nothing. Let it sit for a few minutes and tried again... nothing. Let it sit for about 5 minutes, fired right up. I moved it in the garage and shut it down. This morning when I went to leave, the car wouldnt start. It cranks just fine, but will not fire at all. Fuel pressure at the rail is good, ignition module, cap, and rotor are new, battery is good. The FSM seems to indicate a faulty VATS decoder module (code 46), but I havent tried to pull a code yet. I'm thinking that last night's episode did something to it, and when I shut it down, something in the module went haywire. Sound right?
__________________
"Two in a row, everybody knows at the green light you rev it on the redline..." Foreigner
Lowlevlflyer is offline  
Send a Private Message Reply With Quote
Old 07-31-2009, 09:00 PM   #2
vetteoz
Smokin 2500HP Pro Road Racer
 
Join Date: Jan 2009
Posts: 2,849
Default

Quote:
Originally Posted by Lowlevlflyer View Post
Where can I find a new VATS decoder module? None of the usual catalogs seem to have it. I'm guessing this is a dealer only part?
You don't state what year you have so more than likely it is a discontinued item.2nd hand from wrecking yard and then you would need new key to match the decoder.

Test proceedure
http://www.thirdgen.org/vats_passkey_system

Alternative is to bypass

http://www.corvetteforum.net/c4/rayquayle/vats/vats.htm

http://www.joestradingpost.com/vats/
vetteoz is offline   Send a Private Message Reply With Quote
Old 08-01-2009, 04:35 AM   #3
Lowlevlflyer
Smokin 300HP Club
 
Join Date: Oct 2008
Location: Southern Oklahoma
Posts: 392
Default

Quote:
Originally Posted by vetteoz View Post
You don't state what year you have so more than likely it is a discontinued item.2nd hand from wrecking yard and then you would need new key to match the decoder.

Test proceedure
http://www.thirdgen.org/vats_passkey_system

Alternative is to bypass

http://www.corvetteforum.net/c4/rayquayle/vats/vats.htm

http://www.joestradingpost.com/vats/
1987. Looks like partsladi on Ebay has a few. Might buy a spare and put it on the shelf, some of this stuff is becoming hard to find.
__________________
"Two in a row, everybody knows at the green light you rev it on the redline..." Foreigner
Lowlevlflyer is offline   Send a Private Message Reply With Quote
Old 08-02-2009, 06:28 AM   #4
don'taskdon'ttell
Smokin 100HP Club
 
don'taskdon'ttell's Avatar
 
Join Date: May 2008
Location: Ladson, SC
Posts: 174
Default

Quote:
Originally Posted by Lowlevlflyer View Post
1987. Looks like partsladi on Ebay has a few. Might buy a spare and put it on the shelf, some of this stuff is becoming hard to find.
that is what I do, when I have to buy something even if I don't I'll keep my eyes open for a good deal and buy extra parts just in case because it is tough to find alot of this stuff.
__________________
If you have to ask me if my vette is fast, I'm not going to tell you!
don'taskdon'ttell is offline   Send a Private Message Reply With Quote
Old 08-02-2009, 03:40 PM   #5
khan2305
Smokin 1000HP Twin Turbo Club
 
khan2305's Avatar
 
Join Date: Jan 2008
Location: Tampa, FL
Posts: 1,147
Default

Quote:
Originally Posted by Lowlevlflyer View Post
1987. Looks like partsladi on Ebay has a few. Might buy a spare and put it on the shelf, some of this stuff is becoming hard to find.
Good quality?
khan2305 is offline   Send a Private Message Reply With Quote
Old 08-03-2009, 03:27 AM   #6
Lowlevlflyer
Smokin 300HP Club
 
Join Date: Oct 2008
Location: Southern Oklahoma
Posts: 392
Default

Quote:
Originally Posted by khan2305 View Post
Good quality?
Talked to them on the phone, the guy said the ones they have are OEM and not aftermarket units.
__________________
"Two in a row, everybody knows at the green light you rev it on the redline..." Foreigner
Lowlevlflyer is offline   Send a Private Message Reply With Quote
Old 08-05-2009, 05:05 AM   #7
Lowlevlflyer
Smokin 300HP Club
 
Join Date: Oct 2008
Location: Southern Oklahoma
Posts: 392
Default

Okay, got a new VATS module sitting here looking at me. My question is, how do I GET to the old one? I know it's behind the dash, I think on the passenger side, but the FSM doesnt show or tell the procedure of what to disassemble to get to it!
__________________
"Two in a row, everybody knows at the green light you rev it on the redline..." Foreigner
Lowlevlflyer is offline   Send a Private Message Reply With Quote
Old 08-05-2009, 03:01 PM   #8
Lowlevlflyer
Smokin 300HP Club
 
Join Date: Oct 2008
Location: Southern Oklahoma
Posts: 392
Default

Found the module location and changed them out. DID NOT solve the problem. Engine still cranks but will not fire. I have good fuel pressure at the rail, I've changed out the distributor module, cap, and rotor, and have a brand new ignition key, but still nothing. The day I got the new key cut, I came home, put it in the ignition, and the car started right up. I killed it and tried it again, and it was back to the crank/ no start situation. I do know I am going to have replace the battery tomorrow evening when I get home, as I'm having to keep it on the charger while trying to start the car. The engine cranks over fine when the battery is charged, but could the battery be causing the problem I'm having? I know I read somewhere that the injectors have to have X amount of voltage in order to operate. I have GOT to get this fixed by Sat. or I'm going to be afoot!
__________________
"Two in a row, everybody knows at the green light you rev it on the redline..." Foreigner
Lowlevlflyer is offline   Send a Private Message Reply With Quote
Old 08-06-2009, 04:43 AM   #9
Lowlevlflyer
Smokin 300HP Club
 
Join Date: Oct 2008
Location: Southern Oklahoma
Posts: 392
Default

Anybody??
__________________
"Two in a row, everybody knows at the green light you rev it on the redline..." Foreigner
Lowlevlflyer is offline   Send a Private Message Reply With Quote
Old 08-06-2009, 05:19 AM   #10
vetteoz
Smokin 2500HP Pro Road Racer
 
Join Date: Jan 2009
Posts: 2,849
Default

There is a min battery volts needed to run car. I would be doing any testing with a fully charged battery to eliminate a low V problem.
Crank and no start indicates that you are not getting the signal to pulse the injectors.
Do you have any current codes?
vetteoz is offline   Send a Private Message Reply With Quote
Sponsored Links
Advertisement
 
Reply

Share This Thread
  • Submit Thread to Digg
  • Submit Thread to del.icio.us
  • Submit Thread to Facebook
  • Submit Thread to StumbleUpon
  • Submit Thread to MySpace
  • Submit Thread to Twitter
  • Submit Thread to Google
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -8. The time now is 08:21 AM. Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2006-2009 © SmokinVette.Com