'95 idles too fast, won't shift out of first - SmokinVette.com Forums
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 2 (permalink) Old 12-30-2012, 12:33 PM Thread Starter
Smokin Member
 
Join Date: Mar 2009
Location: Florida
Posts: 1
'95 idles too fast, won't shift out of first

Water pump was leaking at block. Took it off and washed grease from front of block. After reinstalling pump, engine started and ran fine while refilling coolant. After restarting, now engine idles at 2000 rpm, and trans will not shift out of first. Replaced IAC as it was pretty crusty and stiff. No help. Anybody experience this?
bigdonkey is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-08-2013, 02:37 AM
Smokin 2500HP Pro Road Racer
 
Join Date: Jan 2009
Posts: 2,849
Quote:
Originally Posted by bigdonkey View Post
now engine idles at 2000 rpm, and trans will not shift out of first.
Have you pulled the codes from the PCM ( computer) to see if any faults are showing?
On your car the PCM controls trans operation

"Being able to "think outside the box" presupposes you were able to think in it." --Bob Lutz
vetteoz is offline  
Sponsored Links
Advertisement
 
Reply

Share This Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the SmokinVette.com Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome