thermal time cold start switch - Forums
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 4 (permalink) Old 11-03-2009, 03:33 PM Thread Starter
Smokin Member
Join Date: Nov 2009
Location: Richmond, Va
Posts: 1
thermal time cold start switch

I have a 85 vette that runs very rough when cold. I discovered that there is no fire going to the Thermal time cold start switch except in the starting mode. When the switch is released, the wire going to the thermal switch loses it fire. my question is, is there a relay or what controls the fire going to the thermal switch.
shlowe is offline  
Sponsored Links
post #2 of 4 (permalink) Old 11-08-2009, 01:24 PM
Smokin 400HP Club
Join Date: Aug 2009
Posts: 492
From what I read, the cold start in injector only operates while cranking a cold engine.
I think you need to check f. pump press. & make sure it holds press. when the key is off. An inj. leaking raw fuel will make it run rough. Check your coolant temp. senser for restistence.
20*f=13500 olhms
40*f=7500 olhms
70*f=3400 olhms
Those above are typical room temps(on a cold eng.)
-40*f=100700 olhms
210*f=185 olhms, fully warmed up engine.
Good luck
ex-x-fire is offline  
post #3 of 4 (permalink) Old 01-05-2010, 02:38 PM
Smokin 2500HP Pro Road Racer
Join Date: Jan 2009
Posts: 2,849
Originally Posted by shlowe View Post
. I discovered that there is no fire going to the Thermal time cold start switch except in the starting mode.
That is correct operation.
If the CSI was not working you would have to crank longer to get it to start but would not affect general running
vetteoz is offline  
post #4 of 4 (permalink) Old 02-01-2010, 06:01 PM
Smokin 200HP Club
bc.boy's Avatar
Join Date: Jan 2010
Location: Kelowna B.C. Canada
Posts: 282
i have same problem.just spent 4 months rebuilding everything i could take on and got code for coolant temp sensor[the one under the plenum]. I believe it is the sensor as my cooling fans kick in at startup.this would cause computer to believe the engine is warm and cut power to the cold start injector
bc.boy is offline  
Sponsored Links

Share This Thread

Quick Reply

Register Now

In order to be able to post messages on the Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome